PlatformIO Community

Platformio in vscode cannot open home page

I had installed platformio 4.1 for vscode today. But it could not open home page. All other pages could not opened yet except that CLI.

Can anybody tell me why?

Show the output of the pio home command. Any errors?

1 Like

I have the same problem starting today: PIO Home doesn’t open in Visual Studio Code.

Calling pio home doesn’t report any errors:

PS O:\ESP32\ESP32_Leds> pio --version
PlatformIO, version 4.1.0
PS O:\ESP32\ESP32_Leds> pio home

  ___I_
 /\-_--\   PlatformIO Home
/  \_-__\
|[]| [] |  http://127.0.0.1:8008
|__|____|_______________________

Open PIO Home in your browser by this URL => http://127.0.0.1:8008
PIO Home has been started. Press Ctrl+C to shutdown.

PIO Home loads in the browser but it’s still not able to load recent news or any of the libraries, devices nor platform lists - all I see is this spinning Loading icon.

Did you let VSCode auto-update beyond 1.39 which is known to break a lot of stuff? (refer PIO, VSC can't build, no tasks found)

Yes, I’m running VSC on the latest 1.40.2 version - I’ll try to downgrade to 1.39 to see if this helps, thanks!

Version: 1.40.2 (user setup)
Commit: f359dd69833dd8800b54d458f6d37ab7c78df520
Date: 2019-11-25T14:54:45.096Z
Electron: 6.1.5
Chrome: 76.0.3809.146
Node.js: 12.4.0
V8: 7.6.303.31-electron.0
OS: Windows_NT x64 10.0.18363

my vsc had erro messages when I ran “pio home”. What can I do?:cold_face:

PS D:\temp\powerload> pio home

I
/-
–\ PlatformIO Home
/ _-

|[]| [] | http://127.0.0.1:8008
|
|____|______________________

Open PIO Home in your browser by this URL => http://127.0.0.1:8008
PIO Home has been started. Press Ctrl+C to shutdown.
Error: {‘code’: 4999, ‘message’: “[WinError 123] The file name,directory name,or volume label syntax is incorrect。: ‘C:\\Users\\Administrator\\.platformio\\.cache\\on\\https:’”}
Error: {‘code’: 4999, ‘message’: “[WinError 123]The file name,directory name,or volume label syntax is incorrect。: ‘C:\\Users\\Administrator\\.platformio\\.cache\\on\\https:’”}

But PIO home can display in browser at “http://127.0.0.1:8008

@Leon That error is coming up because for some reason you’re trying to access PIO Home via https, not http. Do you have any extensions or settings that try to force https when http is used?

Error: {‘code’: 4999, ‘message’: “[WinError 123] The file name,directory name,or volume label syntax is incorrect。: ‘C:\Users\Administrator\.platformio\.cache\on\https:’”}