PlatformIO IDE: Goto Declaration messed up in3.0

In 2.0 version IDE I used “GoTo Declaration” successfully (at least within one file. I don’t think I ever got it to open a library file for declaration though).
But now this same command brings up this strange window (attached picture).
Similar command “Go To declaration” (what is the difference intended?) does not do anything just as before :smile:

Have a slightly different behavior ( but also seemed to be broken) than Vlad:
a. There are 2 "Got To Declarition"s in the drop down .
b. Second "Go To " doesn’t work at all.

the first one is misspelled as “Goto Declaration”. If i use it, it will either show the drop down list of files (as can be seen on the picture) or will produce nothing.
For example:
DW1000.begin → goto declarion-> opened the dialog on the picture. None of the files are correct BTW. → goto declaration → makes no effect.

These problems are in IDE 1.5.0 | CLI 3.0.1

just upgraded to IDE 1.6.0 | CLI 3.1.0

Still the same (broken) behavior .

I think that the “goto” only “understands” the global/main arduino’s libraries.

The “go to” on “Serial.begin()” would get a list of files. the “gotto” on my library function - won’t do a thing.

Andrew, your problem is basically the same as I reported. Two menu links, one does not do anything another “goto declaration” brings something confusing (depending on where the file located). Unfortunately, although this is a good promising platform, yet ability to step through declaration/definition of a function regardless of where it is located, is to me among the basic requirements. If this is not fixed rather soon, I might be forced again to check out other IDEs…

We use Atom’s autocomplete-clang package for that. I’ve just tested it and have the same problem. The only one solution is to select “instance+method”, instead of method. See picture:

This package doesn’t expose instances :frowning: Please fill free issue here Issues · yasuyuky/autocomplete-clang · GitHub

P.S: This package could be great addition Sunsetting Atom | The GitHub Blog

for some reason i thought i’m subscribed to the updates to the thread - i was not.

Vlad i’m with you - i’m very close to go back to CodeBlocks and maybe just to the professional IDE - all these little things with IDE ( not with PIO) are rather annoying.

Anyway, i see No autocomplete on Includes · Issue #126 · yasuyuky/autocomplete-clang · GitHub filed , plus @Ivan filed 105 and 109.

You can use PlatformIO with other professional IDEs:

Thank you Ivan - for me idea of platformIO + NetBeans is very promising but at this stage I don;t have time to work on that integration … I need a “turn key” plugin- just download, install and continue development…
If I may make suggestion - don;t waste time using immature IDE and instead make a “turn key ready” plugin of your platformIO with Netbeans which is open source… It is one of the best mature and intuitive IDEs within open source (the most intuitive of all for me) but the only “ready made” plugin there for Arduino is a joke compared to your platformIO. Bringing platformIO range of target boards with it’s easiness of toolchain installation + Arduino libraries to the NetBeans should be a winner.
I don;t want to be negative but integrating so much good efforts with immature IDE you won’t go far.
Just my 2cents

Here is native plugin for NetBeans:

Not sure but I think that is the one I already tried - lost 2 days… True plugin should not take other steps than just download plugin into Netbeans and run…including Serial Monitor

Please report all issues here Issues · gholdys/nbpio · GitHub

Grzegorz will help you.