Platformio command not found

I have been using the pio cli for some time. I had installed the ide before the cli and I didn’t care for the IDE (I’ll try again soon).

Today I lost my .atom folder and pio broke. I traced it down to some broken symlinks in usr/local/bin. I deleted them thinking a new pio install would restore them. I tried the curl install and the pip. Neither fixed things. I re-installed the ide and the cli still doesn’t work.

The build in the IDE works so I know platformio executable is hiding somewhere in my system. How can I fix this?

I manged by sheer luck to find the executable. It was at ~/.atom/packages/platformio-ide/penv/bin/platformio. I hope this helps anyone else with this problem.

P.S. The installer really should install the symlinks automatically.

Edit: Also, the cli stuff shouldn’t be in the atom folder. Anyone who removes atom will break the cli.

Please file an issue here Issues · platformio/platformio-atom-ide · GitHub

We will move penv folder to ~/.platformio/penv.