PlatformIO Community

Platform IO failed to work on MAC after auto update

My students that own a MAC keeping getting this error " Error: Condo Virtualization: [Errno 13] Permission denied …" for the Platform IDE extension. One week it works on the MAC. then it stops working . Seems to be due to some auto update. Operating system is macOS Mojave version 10.14.16. Please help. We’ve tried completely reinstalling and still the same error.

Do you have a full error code with stacktrace?

Error: Conda Virtualenv: [Errno 13] Permission denied: '/.cph_tmp50mrqawk' 
at s.runCommand (/Users/jiahaotang/.vscode/extensions/platformio.platformio-ide-1.9.3/node_modules/platformio-node-helpers/dist/index.js:1:30324) 
at ChildProcess.h (/Users/jiahaotang/.vscode/extensions/platformio.platformio-ide-1.9.3/node_modules/platformio-node-helpers/dist/index.js:1:6292) 
at ChildProcess.emit (events.js:182:13) 
at maybeClose (internal/child_process.js:962:16) 
at Process.ChildProcess._handle.onexit (internal/child_process.js:251:5)

Please upgrade your conda installation or remove it from machine and use official Python 3. Then , remove ~/.platformio/penv folder and restart VSCode.