PlatformIO Community

Platform_io_error file formatting?

Hi, I’m new here and a beginner with ESP32, Linux and embedded systems. So I apologise if I’m asking really dumb questions.

I’m using a Raspberry Pi 4 with the latest 32 bit operating system. I’ve successfully installed VS Studio code and Platform IO. Using the Project Wizard to create my first project using the Espressive IOT Development Framework fails.

To help me diagnose the problem I’ve tried to copy the text in the results pop up window which tells me it has failed. I can’t find a way to do this. There is a lot of text. It seems to be replicated in my Documents folder in a file called Platform_io_error. However this also has a lot of HTML like text formatting characters which neither of my editors will ignore. I don’t really want to spend time removing them manually which is why I’m asking what markup format is used. Then I can find an appropriate editor.

For what its worth the problem seems to be a failure to load the liblto.plugin.so plugin.

Thanks, and stay safe,

Steve

Let’s make sure you can compile the basic examples. Do on the commandline (you must have exported PlatformIO into the PATH)

cp -r ~/.platformio/platforms/espressif32/examples/espidf-blink .
cd espidf-blink
pio run -t clean
pio run

Does it show any errors?

1 Like

Max, Thank you for the advice. The basic examples are not installed. After an educational time with a text editor I’ve managed to clean up the error file and removed most of the unwanted formatting.

There seems to be a problem here

Error: Processing az-delivery-devkit-v4 (platform: espressif32; board: az-delivery-devkit-v4; framework: espidf)

So I need to investigate that. I tried to post the whole file but I’m new here and am not allowed to.

Regards,

Steve

Can you upload it to pastebin.com and link it here?

My bad, maybe we should have run a pio platform install espressif32 before that to make sure it does.

There was an s missing in the path, I fixed that now.

Hi Max,

Thanks for the change. I deleted ProgramIO from VSC, removed the Espressive framework. Then did a reload of Linux, then reinstalled ProgramIO within VSC. Hopefully that cleaned out the trash.

Using the project wizard I created a new project as before. This time there is a new failure message

Tool Manager: tool-ninja@1.10.2 has been installed!
Updating metadata for the vscode IDE…

Error: Processing az-delivery-devkit-v4 (platform: espressif32; board: az-delivery-devkit-v4; framework: espidf)
--------------------------------------------------------------------------------
Verbose mode can be enabled via `-v, --verbose` option
CONFIGURATION: https://docs.platformio.org/page/boards/espressif32/az-delivery-devkit-v4.html

If I have time later today I’ll send you a link to the entire file. For what its worth there is no rush. I’m a hobby programmer now learning the ESP-32 and C++ for radio and robotics projects.

Stay safe and thanks again,

Steve

I made a mistake Max, its the same error. Here is the content of platformio.ini

; PlatformIO Project Configuration File
;
; Build options: build flags, source filter
; Upload options: custom upload port, speed and extra flags
; Library options: dependencies, extra library storages
; Advanced options: extra scripting
;
; Please visit documentation for the other options and examples
; Redirecting...

[env:az-delivery-devkit-v4]
platform = espressif32
board = az-delivery-devkit-v4
framework = espidf

Max, Here is the complete diagnostic file az-delivery-devkit-v4 - Pastebin.com

Steve

/home/koszonom/.platformio/packages/toolchain-xtensa-esp32/bin/../lib/gcc/xtensa-esp32-elf/8.4.0/../../../../xtensa-esp32-elf/bin/ld: /home/koszonom/.platformio/packages/toolchain-xtensa-esp32/bin/../libexec/gcc/xtensa-esp32-elf/8.4.0/liblto_plugin.so: error loading plugin: /home/koszonom/.platformio/packages/toolchain-xtensa-esp32/bin/../libexec/gcc/xtensa-esp32-elf/8.4.0/liblto_plugin.so: cannot open shared object file: No such file or directory

Hm. It really looks like the compiler is not properly executable on the Pi 4. The same was noticed in

Funny that even Mac seemed to have problems with this in past, and you could disable LTO to get around this problem (at the cost of increased firmware size) Doesn't work on macOS Monterey 12.3! · Issue #727 · platformio/platform-espressif32 · GitHub.

But basically there probably needs to be a new XTensa compiler package for the Pi. Please open an issue in Issues · platformio/platform-espressif32 · GitHub about this error.

Max, Thanks, having read through those issues I’ll install a fresh 64 bit version of Rasberian on a spare Pi 4 and try it out. I’ll report back. If that fails I have an Intel based single board system.

Stay safe,

Steve

Max, I can confirm that on both 32 and 64 bit versions of the operating system and VSCode there are problems. I need to get some more diagnostics before I raise the issue formally.

On my M1 Mac there are no issues, which surprised me!

Stay safe in Ukraine and watch out for orcs!

Steve