Platform-ide-terminal sessions lose part of $PATH variable

Hello everyone.

I’m having a weird issue with platformio-ide-teminal atom extension on OSX. When I load up a terminal, the output says:

npm WARN npm npm does not support Node.js v9.4.0
npm WARN npm You should probably upgrade to a newer version of node as we
npm WARN npm can't make any promises that npm will work with this version.
npm WARN npm Supported releases of Node.js are the latest release of 4, 6, 7, 8.
npm WARN npm You can find the latest version at
nvm is not compatible with the npm config "prefix" option: currently set to "/usr/local"
Run `npm config delete prefix` or `nvm use --delete-prefix v9.4.0 --silent` to unset it.

and neither node or npm are available in that terminal. If I run either of the two suggested commands (or if I simply run nvm use 9) I get them back, but only for that terminal session.

Both the default terminal and iTerm (v3.1.5) doesn’t have the same issue.

It looks like it’s a path issue though. With the default terminal, echo $PATH outputs /Users/goffreder/.nvm/versions/node/v9.4.0/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin after executing all .bash_profile script, but in platformio-ide-terminal it outputs /usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin.

This is my current configuration:
platformio-ide-terminal v2.8.0
atom v1.24.0
node v9.4.0 (npm v5.7.1)
nvm 0.33.8
OSX 10.13.3

Thanks in advance.