Pio remote run crashes after uploading

I am using a RPi as github runner for my ci/cd pipeline with platformio remote.
Building the firmware locally and uploading to the remote agent is working successful. But after upload the process crashes with this error:

Successfully created esp32 image.
======================== [SUCCESS] Took 308.73 seconds ========================

Environment    Status    Duration
-------------  --------  ------------
usb            SUCCESS   00:05:08.731
========================= 1 succeeded in 00:05:08.731 =========================
Uploading firmware remotely
Upon execvpe platformio ['platformio', '--force', 'run', '-d', '/home/pi/.platformio/remote/projects/ESP32-Paxcounter-5aeb180fcb93be4d241ea824511f5bfc4da3660a', '-t', 'upload', '-t', 'nobuild', '--disable-auto-clean'] in environment id 547497787456
:Traceback (most recent call last):
  File "/home/pi/.platformio/packages/contrib-pioremote/twisted/internet/process.py", line 397, in _fork
    self._execChild(path, uid, gid, executable, args, environment)
  File "/home/pi/.platformio/packages/contrib-pioremote/twisted/internet/process.py", line 468, in _execChild
    os.execvpe(executable, args, environment)
  File "/usr/lib/python3.9/os.py", line 583, in execvpe
    _execvpe(file, args, env)
  File "/usr/lib/python3.9/os.py", line 616, in _execvpe
    raise last_exc
  File "/usr/lib/python3.9/os.py", line 607, in _execvpe
    exec_func(fullname, *argrest)
FileNotFoundError: [Errno 2] No such file or directory: b'/bin/platformio'
Error: Process completed with exit code 1.

pio system info:

PlatformIO Core             6.1.7
Python                      3.9.2-final.0
System Type                 linux_aarch64
Platform                    Linux-6.1.21-v8+-aarch64-with-glibc2.31
File System Encoding        utf-8
Locale Encoding             UTF-8
PlatformIO Core Directory   /home/pi/.platformio
PlatformIO Core Executable  /home/pi/.local/bin/platformio
Python Executable           /home/pi/.platformio/penv/bin/python
Global Libraries            0
Development Platforms       8
Tools & Toolchains          16

solved after pio cli uninstall and reinstall.