PIO preferences problem

Hi I posted a few weeks ago to ask how to stop PIO presenting the home page on startup. I changed the preferences as suggested, but just to let PIO folks know that there’s a problem as it’s reverted back to the old bevaviour. (I view my .cpp file and the system switches back to the PIO home page)

the upper right tick mark is definitely off?

I changed PIO’s extension settings as per this post:

I didn’t notice if it affected the show at startup check box. The box is currently checked.

I’ll uncheck it on the PIO home page and see how that goes. It’s no big deal, just a minor annoyance.

It’s definitely interesting that the checkbox and the extension setting “Platformio-ide: Disable PIOHome Startup” can get out of sync, those should mean the same thing.