Permission error when installing in VSCode


I get this frustrating error when I try to install PlatformIO in my VSCode:

Error: PIP Core: ERROR: esphome 1.14.3 has requirement platformio==4.0.3, but you'll have platformio 4.3.1 which is incompatible. ERROR: Could not install packages due to an EnvironmentError: [Errno 13] Permission denied: '/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/platformio-4.0.3-py3.6.egg-info/PKG-INFO' Consider using the –user option or check the permissions. at /Users/admin/.vscode/extensions/platformio.platformio-ide-1.10.0/node_modules/platformio-node-helpers/dist/index.js:1:35084 at ChildProcess.d (/Users/admin/.vscode/extensions/platformio.platformio-ide-1.10.0/node_modules/platformio-node-helpers/dist/index.js:1:8215) at ChildProcess.emit (events.js:203:13) at maybeClose (internal/child_process.js:1021:16) at Socket.<anonymous> (internal/child_process.js:430:11) at Socket.emit (events.js:203:13) at Pipe.<anonymous> (net.js:588:12)

I’ve tried removing the .platformio, and changing permissions … but I still get the error.

What is the problem?

Hope u can help me :slight_smile:

/ Oskar

Can you purge all your platformio installations? Also via pip3 uninstall platformio and related packages managers if you have done that?