Nucleo does nothing after code upload

Hello all,

I’m new in PlatformIO and want to use PlatformIO instead of the mbed online compiler.
So i have a clean Install of Atom with Platformio and Clang on windows. No other Packages or else installed.

Now i upload a blinky Programm and the Nucleo (F401RE) does after that nothing. LD1 blinks while uploading but the USER-LED (LD2) don’t blink.
Here my Code:

I hope you can help me. Thank you very much.

Hi @mrkbg1!
Just tried your program with my nucleo_f401re and everything works well.
Please ensure you use latest platform and packages.

I am having the same problem.
pio run --target upload finishes with success, but firmware on the board does not change.
However, when I manually drop firmware.bin onto upload disk, it works just fine.

Could you share your platformio.ini

Btw. a little bit off topic:

I also tried some mbed samples: Simple programs without library work.

But when I use some libraries which works with the online compiler, they never worked with platformio.
Last sample I tried was:

#include "mbed.h"
#include "TextLCD.h"

TextLCD lcd(PA_9, PC_7, PB_5, PB_4, PB_10, PA_8);  // it's an lcd-shield for arduino

int main()

I copied the TextLCD library into the lib folder,
which compiles and upload fine but did not work on the nucleo-f103rb board.


platform = ststm32
board = nucleo_f103rb
framework = mbed

Any hints?


Try to add upload_protocol = stlink to the .ini file.

sorry forgot to paste it.
compiling, stlink and dfu upload works but the library code does not work.

meanwhile i’v tried many libraries and and different versions of mbed (including staged) but i could not make it work.

anyone any suggestions?

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

Sorry, but i could not figured out what that means or what is the reason?

It means I spoke prematurely and without reading the entire post. My apologies.

Could you try the latest development version of ststm32?

  1. pio platform uninstall ststm32
  2. pio platform install

Does it work now?

I needed an extra build (MBED_CONF_PLATFORM_DEFAULT_SERIAL_BAUD_RATE) to compile but
the programm above does not work.
(double checked it with the online compiler)

Please file an issue here with all details. Thanks!