Nodemcu-32s can't compile

I’ve been using platformio for dozens of esp8266 projects no problem. I got a shiny new esp32s Labelled as NODEMCU-32 aithinker.

I created a new project (NODEMCU-32s was the closest match) and have left setup and loop completely blank for now and hit build. It fails as below.

Fairly fundamental, probably really simple issue. Anyone know if I need to fiddle something else elsewhere?

Processing nodemcu-32s (platform: espressif32; board: nodemcu-32s; framework: arduino)
Verbose mode can be enabled via `-v, --verbose` option
PLATFORM: Espressif 32 1.11.2 > NodeMCU-32S
HARDWARE: ESP32 240MHz, 320KB RAM, 4MB Flash
DEBUG: Current (esp-prog) External (esp-prog, iot-bus-jtag, jlink, minimodule, olimex-arm-usb-ocd, olimex-arm-usb-ocd-h, olimex-arm-usb-tiny-h, olimex-jtag-tiny, tumpa)
 - framework-arduinoespressif32 3.10004.200129 (1.0.4)
 - tool-esptoolpy 1.20600.0 (2.6.0)
 - toolchain-xtensa32 2.50200.80 (5.2.0)
LDF: Library Dependency Finder ->
LDF Modes: Finder ~ chain, Compatibility ~ soft
Found 26 compatible libraries
Scanning dependencies...     
No dependencies
Building in release mode
Linking .pio\build\nodemcu-32s\firmware.elf
c:/users/x/.platformio/packages/toolchain-xtensa32/bin/../lib/gcc/xtensa-esp32-elf/5.2.0/../../../../xtensa-esp32-elf/lib\libstdc++.a: error adding symbols: File format not recognized
collect2.exe: error: ld returned 1 exit status
*** [.pio\build\nodemcu-32s\firmware.elf] Error 1
1 Like

Seems like a corrupt toolchain to me. You’ve got enough disk space free right?

Try and delete the folder C:/Users/x/.platformio/packages/toolchain-xtensa32/ and C:/Users/x/.platformio/packages/framework-arduinoespressif32/ and restart the compilation process.

1 Like

Deleted. They were from March this year.
It is now downloading them automatically again.

Then we had a lightening strike and the internet went off.

And that looks to have worked ok.
Great thanks for that. I couldn’t have worked that out from whatever it was telling me.

1 Like