Missing PIO build script

Hi all,

I have set up a pio project that I use to learn about programming bare metal for the stm32f103c8. I am using a black magic probe for programming and debugging the MCU. I am loving pio and the setup went super smooth on my desktop. However, when I cloned the repo to my laptop and tried to build the project I got the following error:

> Executing task: C:\Users\dtvan\.platformio\penv\Scripts\pio.exe run <

Processing genericSTM32F103C8 (platform: ststm32; board: genericSTM32F103C8; framework: arduino)

Verbose mode can be enabled via `-v, --verbose` option
CONFIGURATION: https://docs.platformio.org/page/boards/ststm32/genericSTM32F103C8.html
PLATFORM: ST STM32 (10.0.1) > STM32F103C8 (20k RAM. 64k Flash)
HARDWARE: STM32F103C8T6 72MHz, 20KB RAM, 64KB Flash
DEBUG: Current (blackmagic) External (blackmagic, cmsis-dap, jlink, stlink)
 - framework-arduinoststm32 4.10900.200819 (1.9.0)
 - framework-cmsis 2.50501.200527 (5.5.1)
 - toolchain-gccarmnoneeabi 1.90201.191206 (9.2.1)
Error: Missing PlatformIO build script C:\Users\dtvan\.platformio\packages\framework-arduinoststm32\tools\platformio-build.py!
================================================================================================== [FAILED] Took 0.59 seconds ==================================================================================================
The terminal process "C:\Users\dtvan\.platformio\penv\Scripts\pio.exe 'run'" terminated with exit code: 1.

I could of course copy the build script from my desktop, but I was curious why this happened in the first place.

Many thanks in advance!

It seems that your local copy of the arduino framework package is broken. That file should exist.

Please remove your C:\Users\dtvan\.platformio\packages\framework-arduinoststm32 folder and recompile the project. PlatformIO will redownload a copy of the package.

Thx! That solved the issue. When trying to run build from the IDE I got this error though:

platformio-ide-build not found

But after running pio run from the ci fixed that issue as well. Any clue why that happened?

Okay so doing a PlatformIO toolbar --> Project Tasks -> Build throws that error? Do you have a full error message / screenshot? Then some other packages might be broken, too.