Mbed framework version: how to choose a old one?


I’m working with the ILI9341 and nucleoF401RE, the library Unigraphic can use 16bit SPI if I use mbed.h of a version 127 or older, the version who platformoi installs is the 131. How I can install a previous version of the framework? or there is a way to invoke the mbed.h from another folder but the default? Thanks.

1 Like

I’m also curious about this.

@jano @anweiss could you try this?

pio platform uninstall ststm32
pio platform install https://github.com/platformio/platform-ststm32.git#v1.4.0

Does it work?


after a while I was able to going back to that point in history to check why I was asking this :slight_smile:
so I tried uninstaling of ststm32 and install the version you say, all is ok here, but when I try to compile anything for smt32 he answers:
PackageManager: Installing framework-mbed @ ~3.127.0
Error: Could not find a version that satisfies the requirement ‘~3.127.0’ for your system 'linux_x86_64’
then I tried with a lower version (1.3.0 and 1.2.0), this triggers the install of mbed framework 3.126 and it works!
now I can select 16bits in the spi for the Unigraphic. Thanks!