PlatformIO Community

macOS Big Sur beta & PIO

Hi @ivankravets

I just installed macOS Big Sur on my iMac, and I wanted to give you feedback. I will post here bug if I find any.

First test: I installed Big Sur over Catalina, so far VSCode (latest version) and PIO (latest stable) both work out of the box. I just had to reinstall Git from the Command Line Tool package, as sudo xcode-select --install kept telling me that the servers are busy. The CLI tools package can be downloaded directly here.

I also tried to compile my ESP32/8266 projects, they all compiled and transfered to their respective platforms flawlessly.

A simple Arduino project compiles, uploads and monitors fine too.

Hi @X99,

Thank you so much for your report! Could you navigate to VSCode settings and enable “Using development version of PlatformIO Core” for PlatformIO IDE extension? Now, please run

pio system info

Please share an output here.

There you go:

--------------------------  ------------------------------------------
PlatformIO Core             4.4.0a4
Python                      3.8.2-final.0
System Type                 darwin_x86_64
Platform                    macOS-10.16
File System Encoding        utf-8
Locale Encoding             UTF-8
PlatformIO Core Directory   /Users/x99/.platformio
PlatformIO Core Executable  /Users/x99/.platformio/penv/bin/platformio
Python Executable           /Users/x99/.platformio/penv/bin/python
Global Libraries            0
Development Platforms       2
Package Tools               12
--------------------------  ------------------------------------------

About the 10.16 version: it seems that it’s a “first beta issue”, the correct value is 11.0, not 10.16:

image

I might have found an issue. When compiling for an ESP32, I get this error message:

image

I tried launching list_ports.py:
image

I obtained the same result out of PIO by installing pip3, serial, pyserial and then launching list_ports.py:

image

EDIT: looks like I’m not alone
EDIT2: the issue also exists for other ESP platforms.