Linter v2.0 on platform-ide 2.0.0a8


Does the new linter 2.0 works for you on platformio-ide?
I even tried a fresh install but it doesn’t work.

Can you please give me a hint to get it running?


Please restart PIO IDE 2.0, it should ask to upgrade to v2.0.0.alpha.10. I forced temporary to v1.0 version. Please don’t update “linter” package in v2.0.0.alpha.10.

The new “linter 2.0” broke “linter-gcc”.

I’m working with IDE 2.0.0alpha6, 3.3.0a17 and atom 1.15 on a macOS sierra and the new linter works fine with my arduino mega project (The linter asks for installing some dependencies, which is done
The IDE doesn’t upgrade automatic to the last version (2.0a10), why? Must this done manually?
My other problem with linter on teensy 3.5 still exists.

It works when you start/restart IDE. IDE should notify about new version. Could you check?

There is no notification about a newer version. I have this problem long time before and most time
I install the dev-version manually.

me too, automatic installation never worked form me (Win10, OSX 10.10 and 10.11).
I installed manually.


PS: Linter v2.0 works without installing additional packages after upgrade to platformio 2.0.0a11.