PlatformIO Community

Library not showing in c_cpp_properties.json

I created my first library and I’m trying to install it (tried it as a local folder, with git and from the package registry). But somehow I can’t include my files. I looked in the c_cpp_properties.json file and although my library gets installed with all its files in the .pio/libdeps folder, there is no entry created for it in the c_cpp_properties.json. Do you have any suggestions what the problem might be?

The library dependency (LDF) probably has to recognize the usage of the library first, so do a #include <lib_header_file.h> in your code and build it once, then the IntelliSense should rebuild. If it’s not there, do a Ctrl+Shift+P → Rebuild IntelliSense to force a rebuild.

Thanks for the quick reply!

Is not working when I use it with my library:

#include <LuaOnArduino.h>

I get the compile error:
src\main.cpp:3:26: fatal error: LuaOnArduino.h: No such file or directory

I see. Compatibility checks & wrong manifest info prevents the library from being included properly.

teensy is not a framework, it’s a platform (a platform always refer to a type of microcontroller platform, here platform-teensy). If you only want this to be compatible with platform = teensy projects, put it as platforms. But why limit it to teensy? You can also set * for ‘everything’.

A framework is the underlying code base / SDK, same as the available framework = .. choices in the platformio.ini for a board. For example, arduino, espidf, simba, … See here.

Correct the library.json, remove the .pio folder of the project again and rebuild (assuming you’re pointing to the library via the git link https://github.com/lua-on-arduino/arduino.git that should trigger a redownload of the lib).

1 Like

It worked! Thank you so much for your help!
I wanted to restrict it to teensy because this is the only platform I have tested, but it should work with all platforms I guess