Library manager broken?

Since upgrading to version 3 I have not been able to install any libraries. I get a long list of (about 21) errors, with the last (most recent) being - SSLError: hostname ‘’ doesn’t match ‘’. Then some stuff about checking that I have the latest version (I do, IDE 1.4.0, CLI 3.0.1), then some advice about checking the faq (done that), then another error - Exception AttributeError: “‘FileDownloader’ object has no attribute ‘_request’” in <bound method FileDownloader.del of <platformio.downloader.FileDownloader object at 0x7f2ec5191c10>> ignored. I have no clue what any of this means.

I’ve tried reinstalling PlatformIO but no difference. I’ve downloaded the latest version and tried to reinstall, but the installer told me the same version was already installed.

I’m using Linux Mint Rosa (17.3) on a 64 bit machine.

What am I doing wrong?

Thanks in advance,

Know issue with obsolete Python < 2.7.9. We fixed it in development version and new release is planned next week.

Temporary please switch to development version Redirecting...

WOW!! thanks for the quick response! Your solution fixed it,