Issues with Arduino OPTA Network Interface When Using Static IP

Dear community,

I am working on a project with the Arduino OPTA (similar to Portenta H7). I am encountering an issue where the network interface becomes unresponsive when using a static IP configuration. This occurs particularly when there is a high network load or multiple network reconfigurations within a short period.

I am attempting to debug this issue but have difficulty enabling detailed network debug logs via USB serial on the OPTA. I’ve already tried recompiling libmbed.a with the following mbed_app.json configuration:

json

Copy code

{
  "target_overrides": {
    "*": {
      "lwip.debug-enabled": 1,
      "target.printf_lib": "std",
      "platform.stdio-buffered-serial": false,
      "platform.stdio-baud-rate": 115200,
      "platform.default-serial-baud-rate": 115200,
      "platform.callback-nontrivial": true,
      "platform.all-stats-enabled": true,
      "platform.memory-tracing-enabled": true,
      "rtos.main-thread-stack-size": 32768,
      "cordio.max-connections": 5,
      "target.mbed_app_start": "0x8040000",
      "target.macros_add": [
        "METAL_INTERNAL",
        "VIRTIO_DRIVER_ONLY",
        "NO_ATOMIC_64_SUPPORT",
        "METAL_MAX_DEVICE_REGIONS=2",
        "RPMSG_BUFFER_SIZE=512",
        "LWIP_DEBUG=1",
        "LWIP_DBG_MIN_LEVEL=0",
        "LWIP_DEBUGF=0x80"
      ]
    }
  }
}

Despite these settings, I am still not able to capture the detailed debug logs needed to diagnose the problem.

Has anyone else faced a similar issue or can offer insights on how to properly enable LWIP debug logging to USB serial? Any advice or suggestions would be greatly appreciated.

SOURCE
https://github.com/m4mel-kannnja-crawel-index
https://github.com/hAikYu-an1m3-f1Lm-index

Thank you!