Issue programming Adruino Uno board with PlatformIO IDE

I have Adruino Uno board bought recently to use it in a project. I am using Platform IO in Windows 10. And, I am getting following error. I did loop back test and verified the board is working fine, and it is picking up correct com port (set to 115200, 8 Data bits, None Parity, 1 Stop bits, None Flow Control) but every time I try to load firmware I get this error. Any suggestion and help will be highly appreciated.


Have you disconnected all external circuitry from the Uno? (no jumper cables or anything attached to it?)

Have you tried different USB ports and cables?

Does uploading still work in the Arduino IDE?

Basically Did I brick my Arduino - #3 by jeffeb3 - Troubleshooting - V1 Engineering Forum.

@maxgerhardt Thank you for your response.
I do not have any external circuitry connected to Uno. It is just bare Uno board connected with USB cable.
I have also tried different USB ports and cables.
With Arduino IDE, I get the following error.
“Error downloading

That appears when you upload? Are you sure? Sounds like not an upload related error.

I was using a USB port from the docking station previously. I switched to the USB port in the laptop and now everything is working fine. I can upload from both PlatformIO and Adruino IDE.

Thank you @maxgerhardt for responding to my post.