PlatformIO Community

Issue building stm8

Hello, I was working on a project using the stm8 spl a couple weeks ago without any problems. I had to reinstall the pc and since then I cannot build any stm8 project. Not even the examples. I tried reinstalling PlatformIo and also tried on other pc with the same result. The error that I see when I build is the following

*** [.pio\build\mb208\firmware.ihx] SyntaxError EOL while scanning string literal (<string>, line 1)' trying to evaluate ${TEMPFILE(’$LINK -o $TARGET ${__ldflags_for_hex(env, LINKFLAGS)}’

Is this a known issue? Is there any fix available?

edit:
I was able to make it work by downgrading the platformio core to v5.0.4. It looks like v5.1.0 has problems

Thanks

Indeed, I was able to reproduce this too with

[env:mb208]
platform = ststm8
board = mb208
framework = spl

and the source files from https://github.com/platformio/platform-ststm8/tree/master/examples/spl-blink/src.

CC @valeros

This issue was also reported to https://github.com/platformio/platform-ststm8/issues/27, will be discussed there.

The issue was just resolved and a new ststm8 platform was released.

Just update the ST STM8 platform (in the VSCode GUI or via CLI and pio platform update ststm8) and it should work now.