Interface/.htm are not uploaded after build

Hi All,

Newbie question.
I’m working on an WLED firmware build and I’m trying to edit the interface together with the build.
After building the task and flashing the bin file, The interface does not show to be updated. It’s still on the original state.

Checking through logs, It did not include the htm files.
Is there any way that when I “build” it includes all my changes on the entire project?
I’m only doing some minor changes on it, texts and background page and stuff…

Are the files you changed in the data/ directory? Then you need to reupload the filesystem too.

Hi Matt, Thank you for responding.
Can you provide me some links on how to reupload the filesystem?
I’m really new on this just trying to modify minor details.

Thank you!

I think I found it. I’ll try this. Thanks for the input!

Would have also been documented in PlatformIO docs of course.

tried adding the board_build.filesystem = littlefs and building it, Based on the logs it still didn’t show the “data” folder being retrieved.

If you are only tweaking an existing PlatformIO project that worked fine before you should not add platformio.ini optitons, you might have changed the filesystem type now.

During a “Build” or “Build Filesystem Image” task?

During “Build”… I assume with your question and my answer, The thing I’m doing was wrong…
I hate to ask it but… can I send the Zip file? or share screen?

Again, the “Build” tasks builds the firmware(.elf/.bin), from the C/C++ sources in src/ and lib. “Upload” uploads that firwmare.

The “Build Filesystem Image” creates a filesystem image from all files stored in data/ (by e.g. invoking mkspiffs / mklittlefs / mkfatfs). “Upload Filesystem Image” will upload that new filesystem image.

Depending on in which file(s) you’re making changes, you need to chose either or both.