PlatformIO Community

IntelliSense not working on ARM. Is it working for you?

Hello,

I’m using latest version of VisualCode for ARM 32bits (headmelted) v.1.42 with latest version of PIO.

I noticed that IntelliSense was not working and after trying as many things I could imagine I decided to start from scratch.

Now I have a fresh setup and definitely there’s something I’m maybe missing to do, as it’s not working.

I’m trying with basic examples like Arduino Blink or fresh projects. I can see IntelliSense acting when editing files like platformio.ini, but it’s not acting in cpp files.

Am I missing something to enable IntelliSense?

I noticed that if I go to “Command Palette” and I run the option to reset the IntelliSense database, I get the error “command ‘C_Cpp.ResetDatabase’ not found”… I don’t know if this is of any relevance.

Any hint will be more than welcome!
Thanks

When I tried back with v1.37 or so of VSCode, whilst I could compile code fine, the Microsoft C/C++ extension that provides the IntelliSense handling for C/C++ was not working OOTB, so it sounds like nothings changed there. I suspect the underlying issue is that ARM is simply not officially supported…, so we’re lucky Jay (headmelted) is doing the ARM builds of VSCode for us, but as far as extension compatibility goes, YMMV.

The weird thing is that I’d say I had it working when I did the first tests with PIO a couple of weeks ago… Maybe I was just dreaming and what I remember is the tests on my Mac…

Are there any steps to manually rebuild the IntelliSense data?

P

Anything is possible… maybe it did work for a brief sting, maybe I’m talking nonsense :wink: Different archiectures could respond a bit differenly also… I’m on aarch64 (aka arm64) with a Pinebook, and I’m finding 1.42 of VSCode is not usable with an older Xenial install, as the extension host just keeps locking up, so I can’t even install the PIO VSCode extension. But an older version of VSCode was just fine, and it’s possible newer linux distros or a different flavour might work just fine.

I’m afraid I have no idea what to do with IntelliSense if it doesn’t want to play out of the box…

My Pi4 is quite slow on Ubuntu/ARM64 but very useable on Raspbian/ARM32, and if I had IntelliSense working would be just great.

When editing cpp files I see that the code hints appear just for some keywords and giving unrelated tips (eg starting to type #define will propose a couple of nonsensical options) so it’s more like is not taking the right DB.

1 Like

Probably silly question… is it required to install the extension named IntelliSense C/C++ ?

BTW. Is IntelliSense working for anyone on a Raspberry?

Thanks!

I’ve seen more problems when this extension is installed. Only the Microsoft C/C++ extension should be required, I have perfect Intellisense on Windows 10 with only that extension and PIO.

1 Like