Intellisense broken with wildcard config

Intellisense is broken if using wildcard configurations in extra_config. Tryed already to rebuild Intellisense. Only one node.ini (see project structure) is processed, that from exec_node. If I put node.ini content to platformio.ini after rebuilding Intellisense, everything magically works.

Project structure:


Content of platformio.ini:

extra_configs = src/*/node.ini

base_extra_scripts = 
    pre:scripts/ loads additional src and includes with CPPPATH and SRC_FILTER

Content of

from os import path

PIOENV = env.subst("$PIOENV")

#add include path
    CPPPATH=[path.join(PROJECT_SRC_DIR, PIOENV, "inc")]

#add src path
    SRC_FILTER=["+<"+ PIOENV +">"]

Relevant part of the c_cpp_properties.json is:
“configurations”: [
“name”: “PlatformIO”,
“includePath”: [


With regards,

And what’s in these files?

Ha, sorry) Forgot to attach)


platform = ststm32
board = nucleo_h743zi
framework = arduino
extra_scripts = 


platform = ststm32
board = nucleo_h743zi
framework = arduino
extra_scripts =
build_flags = -I include23

I can’t reproduce the problem. Can you clone, open a CLI, cd into the cloned folder an execute pio init --ide=vscode? Is the resulting .vscode/c_cpp_properties.json still empty?

Still the same…


not appearing in c_cpp_properties.json

MacOS Version: 10.13.6
PIO: 5.2.1
VSCODE: 1.61.0

Hm please open a CLI and execute pio upgrade --dev so that we are on the same version.

I omitted to create that folder, does it change when the folder is created?

Upgraded to dev. Showing still the same version 5.2.1. Nothing changed. Tried with inc folder and without, also with content that is referenced in main.cpp. Still no change in c_cpp_properties.json. It shows only exec_node/inc being added, but not brain_node/inc. Everything compiles.

Might be a Mac specific problem? Post to Issues · platformio/platformio-core · GitHub. I can’t verify it on Mac since I don’t have one.

Issue opened: