Including Amaioranos hsm lib goes wrong on Linux

Recently I started using Amoiranos Hierarchical State machine lib from GitHub - amaiorano/hsm: C++ framework library to simplify state-driven code

When I include the lib in platformIO and library,json with the github url mentioned above, it only downloads a part of the library, only library.json, .piopm and hsm.h.


The repository itself contains a lot more files (see url mentioned above)

On my Windows computer this doesnt seem to be a problem, the library is working fine when I include hsm.h.

But when I try to build this project in Github Actions (Linux) then it can’t find the hsm.h anymore and it looks like its downloading a completly different library.
This is a listing of folder .pio/lipdeps/debug/hsm:

Why is the lib included in Windows (VSCode) platformIO only a part of the github repository?
Why i Github actions downloading a completly different repository?

PlatformIO has a “find actual library sub-folder” logic as seen in PlatformIO downloads subfolder. Recently some improvements have been done in Library without includeDir unpredictable · Issue #3887 · platformio/platformio-core · GitHub, but it seems the behavior is still not perfect, especially when the behavior is different for Windows + Linux.

Open a CLI and execute pio upgrade --dev, then delete the old downloaded library again and have PlatformIO redownload it. Is the behavior still the same? → Please open a new bug report in Issues · platformio/platformio-core · GitHub.

You can fix it the same way as described in the referenced topics though as a hotifx. Fork + add library.json in the root directory.