Include errors detected


What “open folder” do you rever to or do you perhaps rever to “Add folder to workspace”?

I have used it, but it only seems to work if the project folders is directly in “Untitled workspace”.

Wanted to do something like this, but it seems to be uncompatible with PIO.

Untitled workspace

Category 1


Category 2


Category 3



Probably File → Open Folder… which will basically replace the current workspace with the contents of that folder. But it does allow you to have your folder structure however you want it.


Ahh, didn’t think about the “File” menu, thanks.

1 Like

Yes. Sorry I wasn’t that clear… :slight_smile:

1 Like

All good @Werner_Smook @mrred128 … we all have those moments every now and then! (avoids looking at breadboard helper adapter thingy that have been looking for last two days which is sat right in front of me under the monitor… :laughing:)

Доброго дня!
Надоело бороться с ошибкой

Предложенный выше фикс помогает только до следующей перезагрузки vscode.
Как побороть сие недоразумение?

Translated to Russian

VSCode and IntelliSense is sometimes fussy about how you do the #include.

The error should go away if you change #include "main.h" to #include <main.h>

You may need to do a IntelliSense index rebuild…

Перевод с английского

VSCode и IntelliSense иногда суетятся из-за того, как вы делаете #include.

Ошибка должна исчезнуть, если вы измените #include "main.h" на #include <main.h>

Вам может потребоваться перестроить индекс IntelliSense …

1 Like

Спасибо за ответ…
Я, видимо, привёл не тот пример для показа проблемы.
Мне теперь во всех стандартных библиотеках менять <> на “”??? У PlatformIO новый стандарт? Бред какой-то…
Да и про перестройку индекса IntelliSense я слышу не впервые. Не ПОМОГАЕТ!
Топик-то зачем перенесли???.. Эх… Модераторы…
Вариант решения проблемы (УДАЛЕНИЕ каталога .vscode из проекта) в теме из которой мой пост был зачем-то вырезан в отдельную тему помогает ровно до следующего перезапуска vscode.
Всё ещё надеюсь на адекватную помощь.

Translated to Russian:

My apologies, I didn’t realise from your earlier post that it was related to the .vscode workaround that was suggested. I’ll move it back.

No, there is no new standard in PlatformIO… Using "<" ">" has always been the method of referencing the standard include paths, as opposed to the absolute path.

However, it appears you have a different issue. Another solution to try might be to re-create the workspace - i.e. create a new project, and move your source files into it… this is what appeared to worked for someone else.

Мои извинения, я не понял из вашего предыдущего поста, что это было связано с предложенным обходным решением .vscode. Я верну его обратно.

Нет, в PlatformIO нет нового стандарта … Использование "<" ">" всегда было методом ссылки на стандартные пути включения, в отличие от абсолютного пути.

Однако, похоже, у вас другая проблема. Другое решение, которое можно попробовать, может состоять в том, чтобы воссоздать рабочее пространство - то есть создать новый проект и переместить в него ваши исходные файлы … это то, что, похоже, сработало для кого-то другого.

Wow! My problem re moved again, great!
Before contacting you, I myself tried to find a solution to this problem. Nothing helps …
The fact is that projects are compiled normally. This error is very annoying and prevents the identification of true errors.
New project - the same. The new workspace - the same.
Running Vscode as administrator - the same…

Deleting a .vscode directory from a project each time already lead to nervous tick.

My system Windows 10 64 bit.
Vscode last version.
PlatformIO last version.
What My to do?
P.S. My question about the new standard in PlatformIO and about " ", " <> " was sarcastic.

Just can’t win, can I? :blush: :stuck_out_tongue:

Very annoying indeed. I can appreciate that “deleting” from your project would be… nerve racking… what if you delete the wrong folder! :open_mouth:

All I can suggest is to check if your antivirus, if any, is causing it… (turn anti virus off for a minute, delete the .vscode folder, start vscode, let it rebuild and see if the error is gone or not).

If not, you could delete %USERPROFILE%\.platformio\packages, and start vscode, and see if the errors go away after a build.

Next up is to either delete %USERPROFILE%\.platformio and make it completely reinstall when you start VSCode. Or, try pio upgrade --dev from the terminal, and see if upgrading to the dev branch changes anything… it worked for one person.

The real annoyance with this sort of issue is that often others can’t reproduce it, so it’s hard to work out what exactly has gone wrong. :-/

Very funny.
Of all the available options, I just remained to reinstall Windows.
How could I not have guessed?
Thanks for the help.
Keep laughing.

I’ll try… :slight_smile:

Please let me know if you do get any further with this… it would be nice to know that removing Windows and installing Linux isn’t the best option!

I suspected that I would be politely advised to install Linux.
But I did not think that this would be the only solution to my problem.
You do not leave me a choice.
Bill Geitz again loses the next user. Linus Torvalds triumphs.
The second time I ask for help on your forum and get a lot of emotions. Only emotions.
You made my day!

1 Like

Well, if you did insist on using a bloated operating system … :laughing: (I won’t mention that I run it probably 40-50% of the time).

That really shouldn’t be your only option… I am sorry if I sound like a broken record, but if you havn’t done all of the things I mentioned above, give them a try… bit by bit. Whatever is broken might get fixed in the process. It can also be very annoying when something seemingly unrelated updates and breaks things… like when the C++ extension for VSCode updated a month or so ago, and started causing all sorts of IncludePath warnings and clutter…

I just removed platformio from vscode extensions.
The problem is gone.
But I program ESP32. Back return in Arduino again?

If that’s what works for you.

Would have been more rewarding to find out what the actual culprit was though.

Re-installing platformio and all its components at my terrible internet will take about a day, two. If by this time I do not dead, I will report the results without fail.


Compiled the code, uploaded the firmware … And again the same !!!

What to do!?
Linux is not an option, there is no space on the hard disk.

And here I was, ready with the emoticons! :frowning:

Since you’re working with the ESP32, is there any chance you’re doing stuff with ESP-IDF, not Arduino?

What does your platformio.ini look like? Can you provide a sample of a project that won’t work for you?