PlatformIO Community

In VSC Task Window always popping up: "Error: No handler found"


#14

Same here… 1.31 IIRC, and a popup comes up at the bottom right every time that needs to clicked to get rid of it… prior to that it was just a message in the log that went away when it switched to the task terminal.


#15

Can confirm I am also getting this and it’s been bugging me. Doesn’t prevent build from failing. Just every time I build.

Not a confidential project so can provide logs if necessary…


#16

I can also confirm seeing this on the latest VSCode. I’ve seen the “no handler found” error for a couple months but it was non-intrusive, but with the latest update to VSCode it now has the popup which doesn’t get automatically dismissed. This seems to be a bug in the PIO plugin but I haven’t dug into where/what is missing myself.


#17

This is a problem for me, as well.

My setup:

PlatformIO Version: 1.6.0 (2018-12-12)
VSCode Version: 1.31.1 (1.31.1)
macOS Mojave 10.14.2

I have been seeing the “Error: No handler found” errors in the OUTPUT window/tab for quite some time; however the popup window is relatively recent.

Is there any clarity whether this is a native VSCode problem or PIO?


#18

Same problem here, the pop up is annoying


#19

I’ve had that same issue on two debian linux boxes now running VSCode 1.31.1 and PIO Core 3.6.4, and I think it’s related to program AVR / Arduino environments, as my AVR (328p uno and 8mhz bare) projects are giving that error, but my ESP8266 (Arduino also) ones are fine - no errors from them?


#20

Without having tested that it would make sense as my machine at home (AVR/Arduino platform and espressif platform installed) throws those errors as I build for the ESP8266 with Arduino and my machine at work (only espressif) doesn’t (building ESP32 with ESP-IDF)… Both are Win10, VSCode 1.31.1 and PIO Core 3.6.4.


#21

I should probably have been clearer :open_mouth: AVR / Arduino, and ESP8266 Arduino, the latter is not throwing errors, the former is. :wink:


#22

STM32 mbed - also throwing errors.


#23

Same problem here… even if it is harmless, it’s annoying, have to close the popup to read the build results.

PlatformIO Version: 2.0.0 Home 3.6.4 Core
VSCode Version: 1.31.1 (1.31.1)
macOS Mojave 10.14.3
Framework: mbed
Platform: STM32 4.6.0
Board: NUCLEO_F446RE


#24

That worked for me:

Remove all folders from workspace
Remove all extension, and after removing each one, restarting VSCode
Reload extensions
Reopen folders on workspace


#25

This seemed to work for me, as well. Thanks for the suggestion!


#26

Remove (deinstall) extensions, or deactivate?


#27

Seems to work here, too!
Thank you very much for this highly efficient workaround.
I did not deinstall extensions, just disabled/enabled them, including platformio.

[Edit: was not sustainable, error returned after a while]


#28

The error is back :frowning:


#29

Guys, I’m here. How to reproduce this issue? I can’t :frowning: Do you use the latest 1.31.1 release?

What is your list of extensions? Maybe, another extension causes this issue? Could you try to disable all extensions and keep only PlatformIO + C/C++ by Microsoft? This is actually the one extension on the which we depend.


#30

v1.31.1 (user setup) on Windows 10

Still did not find out yet how to reproduce it.
Tried the workaround above, error disappeared, but reappeared after a few build.
Maybe it’s not platformio dependent, but caused by some other VSC extension.


#31

I thought it was only AVR platform related, but one of my ESP8266 projects just started doing this also. I went through and disabled all but the PlatformIO and C/C++ extensions and it went away (VSCODE 1.31.1 + debian linux x64). I selectively turned them back on again, and it seems so far that it is the vscode-icons extension that is triggering the error to come back (robertohuertasm.vscode-icons) - which makes sense as it seemed to rear it’s head vscode-icons had just updated IIRC. My other extensions are markdown related + GitLens + Microsoft Python extension. I’ll update again if it re-surfaces.


#32

Could you try ti disable other extensions and find out which produces this error?


#33

I’m not using this extension (means it is not listed under active extensions), but i do have the error.