I seem to broke Platformio somehow

I am using a Windows 10 desktop with a standard BT Internet nothing fancy.But for the last week I been experiencing problems using any of the buttons like new project open project et cetera, or any of the recent news examples.All I get is a spinning circle:

The same thing happens when I am looking under libraries updates

I can still open a previously made project by clicking on add folder,I have tried deleting Platformio and visual studio code,And reinstalling but unfortunately problem is still there.

Once the programme is loaded I can compile it upload it change it fine.

This is obviously something I’ve accidentally done but if anyone could give me a pointer to solve it I would be very happy.

Sorry if this is not the right group to post it in

Please open a PIO CLI terminal and execute pio upgrade --dev. Then restart VSCode. In the PIO home screen, is the core version now 5.0.4a2? Does your infinite-loading error persist?

Well again you seem to have solved the problem, just one thing when visual studio loads now Platformio alien face appears in the side bar
but platformio does not auto open. If you click on the face You have to go to open and then it loads as normal.
Is there a way of autoloading as it used to do?

Have you made sure that in the extension settings of the PlatformIO extension, “Disable PIOHome Startup” is not checked?

No that setting is unchecked,

Is the first option here also unchecked?

Also how long have you waited after a VSCode restart? It might just take a while for some reason.

No I’m afraid not

And I waited about 10 minutes and still it did not auto load.
But if you open up the project and close visual studio and reopen it, it does reopen with the programme and platformio loaded.