I do not any Cmake tools installed, yet I have a CMakeLists.txt in the root directory?

Hi all,
I have purposely started a new project without having any CMake extensions installed, mostly because I have had nothing but problems with getting PlatformIO and CMake peacefully co-exist - I did see past postings from maxgerhardt that indicated that Cmake doesn’t play nice with a PlatformIO setup.
I only have the following extensions: C/C++ Intellisense (I purposely didn’t install the C/C++ Extension Pack, since that DOES install Cmake), Remote - SSH, Remote Explorer, Remote Explorer, Espressif IDF, Print (from PD Consulting), and of course, PlatformIO IDE. I’m new to using the ESP-IDF since it seems to be a better framework than the Arduino framework - the only thing that I can think might setting up the CMakeLists.txt file is maybe the ESP-IDF extension?
Will I need to worry about CMake since I have this mysterious CMakeLists.txt?
I also had tried to follow the instructions in the lib README file for setting up multiple libraries under the lib folder, and all hell broke loose when I tried that - and that prompted me abandon CMake.
George Wicks