How to set a proxy for PlatformIO CLI?

When i try to initialize a project I run into the following problem:

Installing toolchain-xtensa package:
Error: [API] Could not connect to PlatformIO Registry Service. Please try later.

I am quite sure the issue is the proxy but, how to set a proxy for the PlatformIO CLI on Windows?

(set http_proxy=http://your_proxy:your_port does not help)


You can also configure proxies by setting the environment variables HTTP_PROXY and HTTPS_PROXY:

$ export HTTP_PROXY=""
$ export HTTPS_PROXY=""

As far as I know that’s the way to go on unix like systems.
But as mentioned for Windows “set http_proxy=http://your_proxy:your_port” should work, but does not.

Upper case is required!

> set HTTP_PROXY=""
> set HTTPS_PROXY=""

See also this thread

Great, that’s the solution.
Thank you very much!

Thank you too! I moved this topic to FAQ