How to jump to code in libraries etc

I’ve started to use the PlatformIO IDE and think it’s great - problem is that there’s no real easy way for me to jump to reading an included library, method, class, object or variable.

I think in something like IntelliJ I’m able to hold the Command key, and then hover over an element and then simply jump to the library (for example) so that I can read and see the source for it.

Also, I’m not sure why the PlatformIO library installer puts my installed libs, so jumping to them at the moment is a little bit of a mystery and I generally find myself on their github page or downloading the .zip and vim-ing the files.

Hi @Michael_J_Andy!
Have you tried "Go to declaration" from right-click context menu or F3 hotkey?

See Redirecting...

P.S: Please try out PlatformIO IDE for VSCode, it has an excellent Code Intellisense Engine.

Got it, thanks guys. I had tried that previously by installing a plugin to do it and the different “Go to declaration” function didn’t seem to be working. I uninstalled it and now the similar but different “Goto declaration” function seems to be working.

Found it actually, this didn’t work: Sunsetting Atom | The GitHub Blog

We don’t use CTAG. The all data for code completion and linting is dynamic.

I’m having this issue on windows too.
I try to jump to declaration of a function or for instance select one of the includes <X.h> and press F3 or “Jump to declaration” from menu and nothing happens. I was expecting that when selecting one of the includes stated on my .cpp/.ino, or when selecting a class name/method call that is implemented on an external library, and pressing F3 it would open that in the editor

Sorry for reviving an old thread but couldn’t find any info regarding this.