PlatformIO Community

Help no Home button

I feel like a fool I have spent hours trying to get Platformio to work I installed the VScode and do not have a home button on the bottom see picture. Am I supposed to have a login? If yes where do I register? I also not able to connect to the server at 127.0.0.1:8008 I get an error

Firefox can’t establish a connection .

I take it you installed the extension, and then restart VSCode as prompted? Did you get any error messages from the terminal window down the bottom? Did it successfully install?

Next thing to try would probably be to go to Help -> Toggle Developer Tools and click on the Console entry. Then go to View -> Command Palette and type in reload for Developer: Reload Window… and see what comes up in the console log when you do that.


I also not able to connect to the server at 127.0.0.1:8008

Putting the cart before the horse a bit there… :wink: For that to work, you’d need to have PIO Home running…

Am I supposed to have a login? If yes where do I register?

Supposed to… no, but you can register for one, which you will need if you want to use the remote features. I’m not sure of the registration link off hand, but you’d have a link to click on if PIO Home was working…

pfeerick thank u for replying I do not see a restart button in my screen shot posted above. Platformio installs in 2 seconds and what I have is in the pic posted I do not see a restart button is it hidden in a drop down? I almost feel that platformo is not installing it just has the blue button that says disable and Uninstall next to the icon picture.

pfeerick it finally loaded. It would not install over wifi had to use a hard line. Now I have to figure out how to enter a name for a new project

1 Like

A notification would have come up a few seconds after installing the PlatformIO extension at the bottom right informing you it (the VSCode extension) was installed and to restart VSCode (which installs the actual PlatformIO core).

Now that it’s loaded, you want to look for that house icon in the status bar so you can open PlatformIO Home to create a new project. Note you may hit a known bug in VSCode in which you can’t enter text. Double click on the PlatformIO tab up the top if that happens, so that it regains keyboard input focus. Also have a look at the stuff under the PlatformIO alien head icon on the left sidebar when you have a project open. :wink: