Help beginning with mbed nucleo_f103rb

I’m new to mbed and have problems linking the Examples from UIPEthernet (ID:1484) Library with the following error:

Dns.cpp:(.text._ZN9DNSClient13getHostByNameEPKcR9IPAddress+0x1e): undefined reference to millis' Dns.cpp:(.text._ZN9DNSClient13getHostByNameEPKcR9IPAddress+0x9c): undefined reference to vtable for IPAddress’
collect2: error: ld returned 1 exit status

Maybe someone has a hint where to start?


PS: Found an online compiler here which compiles the UIPEthernet examples.

Does this board have Ethernet interface?

no, i took a external ethernet board.
but its working with the online-compiler.

@valeros do you have any ideas?

I have no project for this library I only wanted to test the board and platformio’s debug features.
It’s not a big problem for me if this example does not compile, so i tried out a wiznet 5100 ethernet shield.

Unfortunately the st-link debug interface is not accessible any more when i plug in the ethernet shield.
I went through the nucleo f103 schematics and did not find a connection between SWD clock/data and
the MOSI/MISO/SCK used by the ethernet chip.

Has anyone tried debugging with SPI-peripherals?

Please wait, I’m working on a new configuration for all ST STM32 boards. I’ll ask here to-retest