PlatformIO Community

Getting started


#1

I’m eager to try out platformIO, however the “getting started” instructions fail for me in both atom and VScode.

I see this is similar to an issue open on github since last September:

I tried the latest development build without success.

I’m using OSX 10.12.6

Are there any better guides to getting started?

The error I’m seeing in both VS and atom is:

Virtualenv Create: Traceback (most recent call last):
File “/Users/tim/.platformio/.cache/tmp-49633ja7y5B9btqke/virtualenv-14.0.6/virtualenv.py”, line 2304, in
main()
File “/Users/tim/.platformio/.cache/tmp-49633ja7y5B9btqke/virtualenv-14.0.6/virtualenv.py”, line 705, in main
symlink=options.symlink)
File “/Users/tim/.platformio/.cache/tmp-49633ja7y5B9btqke/virtualenv-14.0.6/virtualenv.py”, line 924, in create_environment
download=download,
File “/Users/tim/.platformio/.cache/tmp-49633ja7y5B9btqke/virtualenv-14.0.6/virtualenv.py”, line 877, in install_wheel
call_subprocess(cmd, show_stdout=False, extra_env=env)
File “/Users/tim/.platformio/.cache/tmp-49633ja7y5B9btqke/virtualenv-14.0.6/virtualenv.py”, line 783, in call_subprocess
% (cmd_desc, proc.returncode))
OSError: Command /Users/tim/.platformio/penv/bin/python2.7 -c “import sys, pip; sys…d”] + sys.argv[1:]))" setuptools pip wheel failed with error code 2


#2

Have you resolved this issue?


#3

I tried it on another computer and it worked, so it’s something to do with python setup on that computer I guess.

Issue still remains unsolved on the original computer.

I thought this was the kind of problem that virtualenv was designed to solve…