PlatformIO Community

FreeBSD Adafruit HUZZAH ESP8266 tool-mkspiffs

Hello,

I’m just beginning to use platformio, and have tried compiling and uploading a few projects to several different boards. I’ve been successful with Arduino uno, Adafruit feather 32u4, and Adafruit trinket pro. Two that I’ve had trouble with are teensy 3.6, and Adafruit huzzah esp8266. I can initialize the project for the huzzah (pio init --ide vim --board huzzah), and build the program with make, but “make upload” fails with the following:

PackageManager: Installing tool-mkspiffs @ ~1.200.0
Error: Could not find a version that satisfies the requirement ‘~1.200.0’ for your system ‘freebsd_amd64’

I’ve done a search for this and found a couple of previous reports where it was suggested to compile the source for mkspiffs. I compiled the suggested source, copied the executable to ~/.platformio/packages/tool-mkspiffs/, and created a package.json file with the following contents:

{
“name”: “tool-mkspiffs”,
“description”: “Tool to build and unpack SPIFFS images”,
“system”: “freebsd_amd64”,
“url”: “https://github.com/igrr/mkspiffs”,
“version”: “1.200.0”
}

But I still get exactly the same error. Is there something I’ve missed?

Regards,

denverh

Unable to upload for ESP8266 projects due to a missing FreeBSD x64 version of mkspiffs is a general problem. I think @valeros or @ivankravets can have a look at it and update the repositories.

Looks like there’s a mkspiffs for FreeBSD amd64 in bintray, but it’s listed as version 1.102.0, which is apparently not acceptable. Unless there’s some way to tell pio to use that one?

If it would help, I could supply the version I compiled, but I think it’s the same as what’s already in bintray. I also think it’s the same version as what Linux gets. Linux works but FreeBSD doesn’t.

Another thought: If mkspiffs is a problem, is there a way to use esptool.py instead?

Ok, I just successfully used esptool.py to flash an Adafruit HUZZAH ESP8266. The command I used was:
esptool.py --port /dev/cuaU0 --baud 115200 write_flash -fm dio -fs 32m 0x00000 ./blink/.pio/build/huzzah/firmware.bin

Among other things, esptool.py can also be used to erase the flash and report the MAC.