Frameworks and Boards do not load in PIO


#1

Hi - Im brand new to PlatformIO - installed on ubuntu (on a nuc) using vcode. It all seems to be fine, the news stories load etc. ( so connection from Vcode/PlatformIO works) but I get an error to connect when I want to load boards or frameworks.

PIO Core Call Error: Error: [API] Could not connect to PlatformIO API Service. Please try later.

I then tried this in the terminal to load the boards and the same problem but a bit more verbose:

[API] ConnectionError: HTTPConnectionPool(host=‘api.platformio.org’, port=80): Max retries exceeded with url: /frameworks (Caused by NewConnectionError(’<urllib3.connection.HTTPConnection object at 0x7f969265bfd0>: Failed to establish a new connection: [Errno 110] Connection timed out’,)) (incremented retry: max=5, total=1)

I have tried to set the API to use SSL, ensure urllib3 is installed - but not working. I can find some similar problems in the past , but when I installed this in a VM on Fedora it seems to work fine…

Any suggestions?

Many thanks!


#2

What is your Python version in a system?

python --version

#3

Python 2.7.15rc1

Ive been away - now back and trying to sort it out… but not really winning :slight_smile: