Esp32 serial monitor outputs nothing useful


#21

Hm you might want to try the same command but with pio run -v --upload-port COM3 -t upload > compileLog.txt.

Seems like maybe the Arduino IDE upload fixed the bootloader and you can upload only via PIO now?


#22

Bei denm ciomand bekomm ich wieder den error das windows den zugriff verweigert hat


#23

That doesn’t matter because up to this point it should have already compiled and tried to upload it and it’s the commands which matter. Can you upload the log file to pastebin.org?


#24

Where do I find it?
If I folow the path which I executed the comand for I only come to the .platformio folder and than ther does not exists a projects folder


#25

In the same terminal where you have execute that other command, execute cd and it will return the current directory of the terminal.


#26

https://pastebin.com/gQiEcAm1
here is the link to pastebin


#27

Please pio run -t clean and then generate a new log (pio run -v --upload-port COM3 -t upload > compileLog.txt.), this run didn’t generate the compile outputs because the firmware was already compiled.


#28

https://pastebin.com/UfJETynA


#29

Hm I couldn’t find any significant difference between our compile logs. All filesystem paths are properly escaped.

Can you check if you have a 3KB partitions.bin inside .pioenvs\esp32doit-devkit-v1 of the project?

If you erase the flash of your ESP32 and then reflash it with PIO, does the same error still occur? And it goes away after you flash it once with the Arduino IDE?

To erase the chip in the terminal when the ESP32 is connected:

"c:\users\vs code\.platformio\penv\scripts\python.exe" "C:\Users\vs code\.platformio\packages\tool-esptoolpy\esptool.py" erase_flash

#30

yes there is that file


it does not seem to work but i have the suspicion that it is a Decoding eroor from platformio because when i upload and use your 3party tool to look at the Serial data it Looks corect and also the Arduino ide seems to decode it corectly


#31

The error in the terminal comes from the fast that its actually a powershell and it seems to interpret it weirdly. Use Windows+R -> cmd.exe -> copy-paste and execute command in there.


#32

After you erase_flash and upload on the PIO firmware, is it still the case that hterm.exe shows the correct output but PIOs serial monitor doesn’t?


#33

yes it does still Show it corectly in hterm and nothing in platformio


#34

Are you absolutely sure that’s not old output? You see the correct output live on hterm but the wrong output with PIO?

Can you do a side-by-side screenshot with hterm.exe (connect on hterm, press reset on ESP32, wait a little, then disconnect) and with PIOs serial monitor?


#35


it is with a high certenty from the same programm


#36

Can you close all serial monitors again (Ctrl+C in the terminal), open a cmd.exe and execute

"c:\users\vs code\.platformio\penv\scripts\python.exe" -m serial.tools.miniterm COM3 115200

is the output correct now?


#37

it gives me an error with unexpected Tokens


#38

You need to execute it in a cmd.exe again


#39


still Nothing as Output and the other Programm still Outputs Serial data when i conect afterwards


#40


after Pressing the reset button on the board, something did hapen but it does not look promesing