ESP32-IDF menuconfig, PlatofrmIO dragging their feet

Core. Home is a second component, hence the different version number. So you have a newer version of the core than when that feature was released, so good to go.

Via the new terminal button (arrow) or the quick access list (PIO icon then New Terminal).

#3) When clicking the icon Run Task at the lower left it pull up a list of options we can click on like Build, Check, Clean and so on. Why not put menuconfig in that list as well, or an icon for it ?

The quick access icons don’t change depending on what platform you use… so adding a ‘menuconfig’ icon would. Better to either add it to the run task list, which AFAIK is the same as the list of project tasks shown when you click on PIO icon (#1 in the screenshot above). In other words, I agree that a menuconfig option should be added to that list targeting on the espressif32/esp-idf, which should then make it a ‘run task’ option also.

Thank you very much for the information.
My Issue with entering " platformio run -t menuconfig " in the terminal was that I was clicking View → Terminal. Which opens a powershell, and it does not work there. The way you showed opens a PlatformIO terminal and works.

A thing people should be aware of when trying this is if your up and down keys don’t work in menuconfig, as this is what happened to me. Try this: In the terminal click the dropdown arrow and choose “Select Default Shell”


A new window at the top will appear and you will want to choose “Git Bash”


After selecting it, click the garbage can icon in the terminal to close it and then reopen it. It should work then, just remember to resize the terminal large enough for menuconfig to display or it will error out when trying to start.


Yeah, I encountered that too, but hoped it was something that hadn’t been addressed as menuconfig support was only in the dev branch at the time. Thanks for showing how to get it working! :slight_smile:

Any update to this yet? Really would love to get menuconfig working with the arrow keys.

1 Like

I wonder if it could be a VSCode terminal ‘bug’/issue? I’m on Windows atm, and from a separate command prompt (via ‘Windows Terminal’) I ran %userprofile%\.platformio\penv\Scripts\activate to activate platformios python venv, changed into the directory that held a ESPIDF project, and then ran pio run -e esp32dev -t menuconfig to use menuconfig for just that environment, and the cursor keys worked fine there. But not in the VSCode terminal - whether it be command prompt or powershell, but do work with the git bash shell. :-/

Edit: Ok, so it does look to be a VSCode integrated terminal issue - since the official espressif-vscode-espidf extension is afflicted by the same issue, and also had issues with the Windows Terminal preview from the looks of it also… so could be a more insidious Windows 10 issue.

In VSCode terminal you can simulate the up/down arrow keys by using the - and + keys on the numeric keypad/numpad, or - and + (shift + =) on the main part of the keyboard.


@ivankravets Could you please add the comment at the official PlatformIO documentation? I spent one hour figuring out why my arrows keys does not work.

NOTE: Do not use a PS terminal, use the default Shell one, otherwise arrows keys will not work.

I’ve added in this information in menuconfig up/down arrows don't work · Issue #423 · platformio/platform-espressif32 · GitHub to track it.


PlatformIO has implemented ALLOT of slick things to VSCode.
Clearly you guys know what your doing when it comes to Vscode.
Any chance we can plead with you guys to make menuconfig more modern like espressif’s Vscode plugin ? Menuconfig is a powerful thing, and this terminal way is very goofy to work with using “J & K” keys to move around.

PlatformIO’s terminal way.

Espressif’s way.