ESP01 code upload works with Arduino IDE but not with PIO?

I tried esp01-512 and esp01-1m doesnt works, using Silicon Laboratories SI2102 usb to uart. I can upload with arduino IDE the basical code, but not with PIO why ?

(while uploading on arduino ide, touching GPIO 0 to gnd well doing it in PIO too, not works.)

full teminal output: - Share Text & Images the Easy Way

ini configs that i tried:

[env:esp01] platform = espressif8266 board = esp01 framework = arduino
[env:esp01_1m] platform = espressif8266 board = esp01_1m framework = arduino
ESP8266EX, ESP01-1M, ESP01

Go to Solution CLICK

Please try all 3 of the available reset methods.

reset method “3” (nodemcu) worked for uploading like as its on arduino.
(GPIO 0 to gnd while uploading)

but led not blinking ? why?

When you press the reset button or power-cycle the board, does it blink?

no already tried that ways.

same code same pins same devices, looks like code uploaded but why isnt working ?

When you add board_build.flash_mode = dout to the platformio.ini and reupload, does it change anything? What’s the FLASH mode set to in the Arduino IDE?

Flash mode in Arduino ide is “Dout”, like you say, and added that flash mode string to platformio, code uploaded and working right now.




So do i have to make changes on post to help people out there looking for this solition ?
(I did)
@maxgerhardt thanks for all quick help, have nice day.

1 Like

Not really, I just mark it as solved.

In general, people just have to look out that they equalize the PlatformIO configuration for their board with the Arduino IDE settings – if it still doesn’t work after that, that’s a bug. What can be improved though is that PlatformIO gives the same defaults as the Arduino IDE. The esp01 definition does flash mode qio and reset method ck by default, but the Arduino IDE does dout and nodemcu.

1 Like

Thanks a lot for helping. Got an fatal error (28) everytime flashing my esp01 and searched for solutions. Some people with this problem said it could be an older firmware and therefore i updated it but with no success. Then i had the idea that it could be a problem with platformio (i had no comparison to flashing with arduino ide because i always used pio) and searched for a topic and landed here. Now its working fine :).