PlatformIO Community

Error while Building, new to tinyML

Processing esp32dev (platform: espressif32; board: esp32dev; framework: arduino)

Error: Traceback (most recent call last):
File “C:\Users\sak.platformio\penv\lib\site-packages\platformio_main_.py”, line 102, in main
cli() # pylint: disable=no-value-for-parameter
File “C:\Users\sak.platformio\penv\lib\site-packages\click\core.py”, line 1130, in call
return self.main(*args, **kwargs)
File “C:\Users\sak.platformio\penv\lib\site-packages\click\core.py”, line 1055, in main
rv = self.invoke(ctx)
File “C:\Users\sak.platformio\penv\lib\site-packages\platformio\cli.py”, line 71, in invoke
return super().invoke(ctx)
File “C:\Users\sak.platformio\penv\lib\site-packages\click\core.py”, line 1657, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “C:\Users\sak.platformio\penv\lib\site-packages\click\core.py”, line 1404, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “C:\Users\sak.platformio\penv\lib\site-packages\click\core.py”, line 760, in invoke
return __callback(*args, **kwargs)
File “C:\Users\sak.platformio\penv\lib\site-packages\click\decorators.py”, line 26, in new_func
return f(get_current_context(), *args, **kwargs)
File “C:\Users\sak.platformio\penv\lib\site-packages\platformio\run\cli.py”, line 144, in cli
process_env(
File “C:\Users\sak.platformio\penv\lib\site-packages\platformio\run\cli.py”, line 201, in process_env
result = {“env”: name, “duration”: time(), “succeeded”: ep.process()}
File “C:\Users\sak.platformio\penv\lib\site-packages\platformio\run\processor.py”, line 83, in process
install_project_env_dependencies(
File “C:\Users\sak.platformio\penv\lib\site-packages\platformio\package\commands\install.py”, line 132, in install_project_env_dependencies
_install_project_env_libraries(project_env, options),
File “C:\Users\sak.platformio\penv\lib\site-packages\platformio\package\commands\install.py”, line 241, in _install_project_env_libraries
spec = PackageSpec(library)
File “C:\Users\sak.platformio\penv\lib\site-packages\platformio\package\meta.py”, line 184, in init
self._parse(self.raw)
File “C:\Users\sak.platformio\penv\lib\site-packages\platformio\package\meta.py”, line 291, in _parse
raw = parser(raw)
File “C:\Users\sak.platformio\penv\lib\site-packages\platformio\package\meta.py”, line 316, in _parse_requirements
self.requirements = tokens[1].strip()
File “C:\Users\sak.platformio\penv\lib\site-packages\platformio\package\meta.py”, line 231, in requirements
else semantic_version.SimpleSpec(str(value))
File “C:\Users\sak.platformio\penv\lib\site-packages\semantic_version\base.py”, line 647, in init
self.clause = self._parse_to_clause(expression)
File “C:\Users\sak.platformio\penv\lib\site-packages\semantic_version\base.py”, line 1043, in _parse_to_clause
return cls.Parser.parse(expression)
File “C:\Users\sak.platformio\penv\lib\site-packages\semantic_version\base.py”, line 1063, in parse
raise ValueError(“Invalid simple block %r” % block)
ValueError: Invalid simple block ‘^6.19.4ls’

============================================================

An unexpected error occurred. Further steps:

============================================================Preformatted text

Either your platformio.ini or some library used in your project uses this invalid version declaration of 6.19.4ls, which is not SemVer compliant. Hard to say without a platformio.ini given.