PlatformIO Community

Error when publishing a package

I am trying to update my package to PlatformIO, but I now seem to be getting an error message.

pio package publish --owner etlcpp
Preparing a package...
Type:     library
Owner:    etlcpp
Name:     Embedded Template Library
Version:  20.35.3
Size:     546.03KB
Are you sure you want to publish the library etlcpp/Embedded Template Library@20.35.3 to the registry?
 [y/N]: y
The package publishing may take some time depending on your Internet connection and the package size.
Publishing...
Error: Please set a username for your account using the next command:
https://docs.platformio.org/en/latest/core/userguide/account/cmd_update.html

If I enter pio account show then it confirms that I already have a username.

I didn’t have this error all the other times I’ve published.

I tried pio org list but apparently I no longer seem to have etlcpp as an organisation.

pio org list
You do not have any organization

And who’s the owner of the etlcpp organization? CC @ivankravets

I am the owner.
I’ve updated this package several times in the past, but never had this error before.

OK, I haven’t interacted with PlatformIO for a while and it seems I have two valid logins. I tried with my Github login credentials and it now lists Embedded Template Library with me as the owner.
Package update now works.
I should probably delete the erroneous account to avoid issues next time.

2 Likes