Error: programmer is not responding stk500 on raspberry pi. HELP

Uploading Arduino sketches from Windows PC using ArduinoCC software, to Arduino Uno and Mega works fine.
However, trying to do the same from a Raspberry Pi with Platformio results in an upload error:
‘stk500_recv() programmer not responding’. So sketch is not uploading. The is a very quick blink on the Tx led on the arduinos, every time (10 intents) uploading is tried by platformio. so some connection is made.

Port was checked and is /dev/ttyACM0, both when trying to upload sketch (port selection automatic) as when using serial monitor. Python version is 2.7.9.
(much info on internet about this error, but no solutions found)

This could be a problem with udev rules, which control permission to access USB serial ports under linux. A simple check is to try uploading with root permission.

If that works, the proper solution to your problem can be found

1 Like

That is a very interesting suggestion! I will be trying out the options in the next 24h and let the forum know. Thank you from Chile

Problem solved.

  1. installing the rules file as suggested by David.
  2. Many arduinos measure data and send these to the raspberry via the serial port (USB). Apparently one should STOP the python services that read data from the USB/serial port, before trying to upload something back to the Arduino. (Got to this solution thinking about the possible ‘port problems’ suggested by user DavidPowell).

A simple solution, but perhaps worth mentioning in manuals. Many users have services running on a Raspberry which may or may not interfere with port usages by Platformio.

Great forum!!

Hi. Would love some help with a ‘avrdude: stk500_recv(): programmer is not responding’ error message. I saw another post with this message as a title, but didn’t see any responses. Brand new Arduino R3. Soldered on a Adafruit 1.8" TFT Shield. Plugged into an iMac running OS X 10.9.4 w/USB, and I downloaded the latest version of Arduino and the relevant libraries. Under tools in Arduino I chose Board > Arduino Uno and Serial Port > /dev/tty/usbmodem641. I’ve tried restating the computer, Arduino and un/re plugging the USB. Any ideas of what else to try would be great. Thanks kindly.