Error: HTTPS Connection Pool

My OS is windows 10. Maybe in our firm may use proxy . Is there any other way to open home page of Platform io ide. Because of this issue, home screen of platform io is not opening at all

Please click on the “terminal” icon on the bottom status bar and type pio home. Does it open in your default browser?

No, Its not opening. I tried it and got the above error the same as given below

HTTPSConnectionPool(host=‘’, port=443): Max retries exceeded with url: /v3/packages/platformio/tool/contrib-piohome (Caused by SSLError(SSLCertVerificationError(1, ‘[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate (_ssl.c:997)’)))

You will not be able to use PlatformIO because all our servers are blocked by your company. Please contact your system administrator.

one of my colleague installed somehow . How is that possible? He does not remember what changes he did but he is able to do open the home page .

will I able to open home page of platform IO ,If I ask our company to give access for the below link

Could you try to remove %USERPROFILE%/.platformio/penv folder and restart VSCode?

I tried it but issue remain the same.

Please provide an output of pio system info command.

Sounds like the same issue in SSL Certificate Error in VSCode to me – a HTTPS inspector / TLS interceptor in the corporate network is screwing up the certificates. Can you check the certificate chain in the same way as described in that topic and see if it matches mine?

C:\Users\Muthukumar Murugesan>pio system
Usage: pio system [OPTIONS] COMMAND [ARGS]…

-h, --help Show this message and exit.

completion Shell completion support
info Display system-wide information
prune Remove unused data

Where you have given the chain link ?

I showed the certificate chain I see at SSL Certificate Error in VSCode - #9 by maxgerhardt.

Not able to open the page in the web browser

Something went wrong…

Cannot read properties of undefined (reading ‘readFile’)Stack traceReDoc Version: 2.0.0-rc.72
Commit: 2100b549 works for me

Ah yes, the old friend “Zscalar”, your network is employing a HTTPS interceptor and messes with the certificates.

The old topic solved it by asking the admins to add an exception to platformio domains.

Only admins can give this?. Where we have to add this exception ?

Only the ones with acces to the Zscalar.

The admins will know.

Okay Thank you very Much!