Error during BUILD

I get an error message during the Run build task.

Bildschirmfoto 2020-11-08 um 11.06.21

Does anyone know, what this means??

ummm, yes? :wink:

It’s looking for a file named \.platformio\penv\Scripts\pio.exe and cannot find it. As you are running the zsh shell, I’m assuming a Mac or Linux? This is interesting as the directory separators are back to front for those, but perfect for Windows, which is a little confusing to say the least.

Also, if we ignore the direction of the back-slashes, it looks from the file’s path, that you are running in root? Or, at least, from the root (/) folder? Did you install PlatformIO as root?

Whatever the problem, the file it is looking for, pio.exe is nowhere to be found.

HTH (a little!)


Hallo Norman
You are right. It is a MAC.
I installed PlatformIO within VisualStudioCode, so I don’t know exactly whether it is root or not.
If I search pio.exe in the finder; there is no such file on disk.
The projects folder with the actual project is within my user.
What shall I do?
Greetings Matthias

Try uninstalling platformio, exit VSCode then go back in and reinstall.


This is very suspicious. The left is /bin/zsh (is that the default terminal on Mac?) and the right is Windows-style path, since it has backslashes as path seperators. Should be forward slashes.

Also the path to the .platformio directory seems wrong – it is really at the root of the directory? Does /.platformio/penv/Scripts/pio.exe exist? Seems to me that internally PIO thinks you’re on Windows instead of Mac. Does the finder find the file pio?

What exact Mac OS version are you running?

I run macOS Catalina 10.15.7
The finder finds no file pio.
zsh ist the default terminal on Mac OS now.
I have tried VisualStudioCode with platformio in parallels on this mac, but it did not work.
So I deinstalled VisulaStudioCode in Windows.

Should I deinstall platformio an reinstall???

@ivankravets A report of a possible breackage of PlatformIO with the MacOS Catalina 10.15.7 update that was released 3 days ago might be interesting here. The path info in my post above looks suspicious.

I’d usually recommend to uninstall PlatformIO and then install PlatformIO with the installer script and then try to run PlatformIO from the CLI first, but maybe Ivan knows more about this or can test (since I don’t have a Mac)

1 Like

What is it? See platformio-vscode-ide/project.js at 59f3893216e849494784a846a30a9f2aa8cbeffc · platformio/platformio-vscode-ide · GitHub

How did you receive pio.exe on macOS?

It seems you got a shared project from a Windows machine with hardcoded tasks.json. Please remove tasks.json from .vscode folder and restart VScode.

1 Like

I’m macOS user, everything works well here. I’ve not tried the next Big Sur version because there is no stable release.

Thank you all.
I will try to do a complete deinstallation of VSC and platformio on the next weekend and a clean (hopefully) new installation.
I keep you informed.

Deinstallation should not be needed if Ivan correctly identified the source of the problem, just remove the files in the .vscode folder in the project or use the project task to do a Miscellaneous → Rebuild IntelliSense index.