Error compiling marlin

Hi guys
I was compliling marlin firmware for my 3d printer
It was working fine yesterday but I updated PlatformIO and now it’s giving me an error

ModuleNotFoundError: No module named ‘platformio.managers.package’:
File “C:\Users\Rixon.platformio\penv\lib\site-packages\platformio\builder\”, line 167:
env.SConscript(item, exports=“env”)
File “C:\Users\Rixon.platformio\packages\tool-scons\scons-local-4.0.1\SCons\Script\”, line 598:
return _SConscript(self.fs, *files, **subst_kw)
File “E:\printers\firmware\Marlin-2.0.x\Marlin-2.0.x\buildroot\share\PlatformIO\scripts\”, line 12:
from platformio.managers.package import PackageManager

Any ideas ?

I am getting the same error. I only installed yesterday for the first time and haven’t managed to get it working yet. Presumed i was doing something stupid! Happy to see its not just me! :slight_smile:

keen to get it sorted though!

I am getting the same error too.
I see windows make a internet security update this morning.

See Marlin: Help me ERRROR ModuleNotFoundError - #6 by ivankravets

Yep update marlin and she works again

Thks a lot.
It’s work great but the latest version of Marlin is little different of version. You need to make few changements in Configuration.h and .adv for compilation

Is there anything else that has to be changed in new configuration.h ?
After update I experience problem with RE-ARM board. Now when I upload firmware and connect re-arm to computer it doesn’t recognize SD card anymore and loses USB connection after couple of minutes.