Error compiling application using framework-arduinoespressif32 version >= 2.0.7

I’m using this configuration in platform.ini:

platform = espressif32
board = esp32cam
framework = arduino
platform_packages = framework-arduinoespressif32@

Starting from version 2.0.7 I get the following error:
Resolving esp32cam dependencies…
Error! Failed to extract upstream toolchainconfigurations:
Bad package version esp-2021r2-patch5-8.4.0
You can disable this feature via the board_build.arduino.upstream_packages = no setting in your platformio.ini file.

Please report that failure to Issues · platformio/platform-espressif32 · GitHub.

Note that the latest platform-espressif32 version already supports 2.0.7 per releases, so just update your platform. E.g., by using CLIpio pkg update -g -p espressif32

my platform is already updated to latest version:

Platform Manager: espressif32@6.2.0 is already up-to-date

I have opened an Issue on github: