EasyCAT_lib@47eefd8351 or EasyCATlib or 3502

I’m new to programming and especially PlatformIO .
Installed above lib but get error easycat.h no such file in library.
Thought maybe I made wrong and searched and found :
PlatformIO lib install “EasyCAT_lib@47eefd8351”
and got Library Storage:
LibraryManager: Installing id=3502 @ 47eefd8351
EasyCAT_lib @ 47eefd8351 is already installed

Do I do something wrong or is there a problem (As I now believe :- ) with the lib.
What to do except using Arduino , where it works, is there a workaround ?

Can we see the code that you get the error with please? It is probably just a missing path

1 Like

lib_deps = EasyCAT_lib @ 47eefd8351
is in the platformio.ini right?

1 Like

Hi and thanks for looking at my problem !
@ maxgerhart Right have tried 3502 too.
I also tried : EasyCAT_lib - EasyCAT shield library - It allows you to make an… | Mbed
Error: VCS: hg client is not installed in your system
Seams to be something I have not installed.

@Foxa I have reduced my code to a minimum.
as soon as I comment // #include <EasyCAT.h> away it compiles.
( The Lib in Arduino IDE works )

Platforrm.ini :
platform = espressif8266
board = d1_mini
framework = arduino
lib_deps =

Using a library name

monitor_port = COM3

#include <Arduino.h>
#include <PubSubClient.h> // Test if it is included.
#include <EasyCAT.h>

void setup() {
// put your setup code here, to run once:

void loop() {
// put your main code here, to run repeatedly:

@ maxgerhardt
I’m sorry but I can’t find where i found a similar problem about no such file in directory.
My only excuse is that i’m 71 and forget many things these days.:slight_smile:
Anyhow The problem was much deeper than mine but in the beginning you recommended to delete the lib and install it under lib… so I did that.
After some bastel (The guy who wrote it apparently used Arduino (nothing in the cpp file)
I at last got
At the moment I can not test as I have no EasyCAT board right now.
But as it compiled I probably only have to change programming mistakes.

I still think the lib at PlatformIO has a glitch as the lib I installed had quite different errors and to a point understandable for me :- )

So thanks to both of you for supporting !