Duplicate library


Caused by some renaming actions in GitHub I was forced to re-register an existing library:

Can I have this library (1802) unregistered as it is redundant with the following library (1814):

I also noticed that when I do a search on ‘wiegand’ in the library register, the first library shows up, the second not. Any idea why?




Could you try again?

(1) Thanks for unregistering the old instance of the library

(2) Search on platformio,org now also shows the new instance. Did I do something wrong somewhere?

(3) Search on my local platformio still shows the old instance and not the new instance. Should I wait a little more?

(4) PlatformIO Registry lists the latest version (0.5.1) which I uploaded yesterday. On my local platformio/libraries I still have 0.5 installed (from the remote library). It shows that I can upgrade to 0.5.1, upgrading seems to work fine, but my local library remains at version 0.5.

Here’s the confirmation message:

_Library has been successfully updated
_Library Storage: C:\Users\Admin.platformio\lib
_Updating Simple-Wiegand-Library-for-Arduino @ 0.5 [0.5.1]

_Uninstalling Simple-Wiegand-Library-for-Arduino @ 0.5: [OK]
_Looking for Simple-Wiegand-Library-for-Arduino library in registry
_Found: PlatformIO Registry
_LibraryManager: Installing id=1814 @ 0.5.1

_Simple-Wiegand-Library-for-Arduino @ 0.5 has been successfully installed!

Please notice installing 0.5.1, but 0.5 succesfully installed. What can be wrong?

Thanks again!

Just run pio update command. It will remove cache.

I did the pio update, but unfortunately with the same result. Still at V0.5 instead V0.5.1.

Hm… I’ve just tried and can’t reproduce this issue. Could you try this:

  1. Manually remove %HOME_DIR%/.platformio/.cache folder
  2. Manually remove library from %HOME_DIR%/.platformio/lib
  3. pio lib -g install 1814

That indeed seems to make it work.

However (unfortunately again):

  • the correct version was installed (I checked with the version in GitHub)
  • the version 0.5 was still listed in the Installed tab (should have been 0.5.1)
  • uninstall (via the IDE) reported a problem, see below (but the library was indeed gone)
  • again install (via the IDE) installed V0.5 again.

I think there is something wrong with my local platformio instance.

Uninstall problem report:

Library command failed: lib --storage-dir C:\Users\Admin.platformio\lib uninstall C:\Users\Admin.platformio\lib\Simple-Wiegand-Library-for-Arduino_ID1814
Error: Error: Traceback (most recent call last):
File “c:\users\admin.platformio\penv\lib\site-packages\platformio_main_.py”, line 120, in main
cli(None, None, None)
File “c:\users\admin.platformio\penv\lib\site-packages\click\core.py”, line 700, in call
return self.main(*args, **kwargs)
File “c:\users\admin.platformio\penv\lib\site-packages\click\core.py”, line 680, in main
rv = self.invoke(ctx)
File “c:\users\admin.platformio\penv\lib\site-packages\click\core.py”, line 1027, in invoke
return process_result(sub_ctx.command.invoke(sub_ctx))
File “c:\users\admin.platformio\penv\lib\site-packages\click\core.py”, line 1027, in invoke
return process_result(sub_ctx.command.invoke(sub_ctx))
File “c:\users\admin.platformio\penv\lib\site-packages\click\core.py”, line 873, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “c:\users\admin.platformio\penv\lib\site-packages\click\core.py”, line 508, in invoke
return callback(*args, **kwargs)
File “c:\users\admin.platformio\penv\lib\site-packages\click\decorators.py”, line 26, in new_func
return f(get_current_context().obj, *args, **kwargs)
File “c:\users\admin.platformio\penv\lib\site-packages\platformio\commands\lib.py”, line 108, in lib_uninstall
File “c:\users\admin.platformio\penv\lib\site-packages\platformio\managers\package.py”, line 672, in uninstall
File “c:\users\admin.platformio\penv\lib\site-packages\platformio\util.py”, line 636, in rmtree

return rmtree(path, onerror=_onerror)
File “C:\Python27\Lib\shutil.py”, line 256, in rmtree
onerror(os.rmdir, path, sys.exc_info())
File “c:\users\admin.platformio\penv\lib\site-packages\platformio\util.py”, line 634, in _onerror
WindowsError: [Error 5] Access is denied: ‘C:\Users\Admin\.platformio\lib\Simple-Wiegand-Library-for-Arduino_ID1814’


An unexpected error occurred. Further steps:

  • Verify that you have the latest version of PlatformIO using
    pip install -U platformio command


at utils.runPIOCommand.spawnOptions (file:///C:/Users/Admin/.atom/packages/platformio-ide/lib/library/helpers.js:39:25)
at onExit (file:///C:/Users/Admin/.atom/packages/platformio-ide/lib/utils.js:92:7)
at exit (file:///C:/Users/Admin/.atom/packages/platformio-ide/lib/utils.js:102:21)
at triggerExitCallback (C:\Users\Admin\AppData\Local\atom\app-1.19.5\resources\app\src\buffered-process.js:338:17)
at ChildProcess.<anonymous> (C:\Users\Admin\AppData\Local\atom\app-1.19.5\resources\app\src\buffered-process.js:368:17)
at emitTwo (events.js:106:13)
at ChildProcess.emit (events.js:191:7)
at Process.ChildProcess._handle.onexit (internal/child_process.js:215:12)

Could you remove that folder totally?

After I did that “platformio home” does not start up anymore (white frame, endless rotating circle until it times out).

Could you run PIO Home from CLI?

pio home

Thanks, that indeed worked!