PlatformIO Community

Debuger problem for HIFive1 rev B

HI!
In my previous post i asked for help with setting up the debugger and everything worked. Now for some reason debugger keeps shutting down on me for no reason. I would be going line by line and debugger would exit and say “no debug adapter found” . I am running on windows and im debugging HiFive 1 rev b.
Thank you!

Do you use the latest version of SiFive dev/platform? We are going to release PlatformIO Core 4.1 today which bring a lot of improvements to PIO Unified Debugger.

Yes, after the update it works like a dream

1 Like

@ivankravets Funny thing, it worked for a while, now its giving me all sorts of errors. I am just lost with these errors. Everything uploads to the board and works fine, but the debugger just isn’t working.

Program

received signal SIGTRAP, Trace/breakpoint trap.

WARNING: CPU could not be halted ERROR: Communication timed out: Requested 4 bytes, received 0 bytes ! Could not start CPU core. (ErrorCode: -1) WARNING: Target connection lost.

0xdeadbeef in ?? ()

WARNING: Failed to read memory @ address 0x00000000

What is your OS? Did you try to reconnect board?

@ivankravets I am on Windows 10, and yes i tried reconnecting the board. I tried running the debugger on an empty program to see if I did something wrong in the code but with same result. Everything uploads and runs, but debugger is stuck telling me that it cant read register x0 while the CPU is running. What i did prior to this is uninstalled Jlink drivers and the VSCode with PlatformIO. I reinstalled VSCode, PIO and Jlink since and thats when i started to get this issue. I will try to set everything up on a different PC and see if the problem persist. But is there any other troubleshooting steps i can go through meanwhile?

You do not need to install any Segger software. PlatformIO uses own J-Link GDB server which was tested before. Maybe, we a conflict between multiple J-Link software in a system. The drivers are located in ~/.platformio/packages/tool-jlink/drivers folder.

@ivankravets You were right, after uninstalling the Segger software it works like a dream! Thank you!

1 Like