Debug session not starting on max32630fthr

I decided to try out the PIO Unified Debugger, but it’s not quite working as I’d expect. Here’s what I’m seeing:

  • I first tried the mbed-blink example on nRF-52-DK board, using mbed debug. It worked fine with the debugger, other than ignoring breakpoints set at certain lines. Might this be due to a compiler optimization?

  • I then tried the mbed-blink example on a max32630fthr board. This seemed to build ok, but doesn’t seem to actually run on the target. The build and debug session windows end up as shown at the bottom of this message.

  • To test the board and the interface, I next built mbed’s blink program on the mbed online ide and copied the image to the board using windows explorer. This worked normally.

Any help here is appreciated!

_Memory Usage →
DATA: [= ] 10.6% (used 3465 bytes from 32768 bytes)
PROGRAM: [= ] 5.3% (used 13884 bytes from 262144 bytes)
========================================================== [SUCCESS] Took 6.86 seconds ==========================================================

=================================================================== [SUMMARY] ===================================================================
Environment max32600mbed [SUCCESS]
Environment max32630fthr platform [SKIP]
========================================================== [SUCCESS] Took 6.86 seconds ==========================================================

Terminal will be reused by tasks, press any key to close it.


INFO:root:CPU core is Cortex-M4
INFO:root:FPU present
INFO:root:6 hardware breakpoints, 4 literal comparators
INFO:root:4 hardware watchpoints
PlatformIO: Initialization completed
PlatformIO: Resume the execution to debug_init_break = tbreak main

Please file an issue here Issues · platformio/platform-maxim32 · GitHub