Custom ESP32-C3 custom board esptool.py error

I’m working with a custom esp32-c3 board.

This is the .ini file:

[env:esp32-c3-devkitm-1]
platform = espressif32
board = esp32-c3-devkitm-1
framework = arduino

; change microcontroller
board_build.mcu = esp32c3
; change MCU frequency
board_build.f_cpu = 160000000L

THE PROBLEM:
When I try to upload an empty project with no code just as a test I get the following output:

Processing esp32-c3-devkitm-1 (platform: espressif32; board: esp32-c3-devkitm-1; framework: arduino)
---------------------------------------------------------------------------------------------------------------------------------------Verbose mode can be enabled via `-v, --verbose` option
CONFIGURATION: https://docs.platformio.org/page/boards/espressif32/esp32-c3-devkitm-1.html
PLATFORM: Espressif 32 (6.4.0+sha.f6ec392) > Espressif ESP32-C3-DevKitM-1
HARDWARE: ESP32C3 160MHz, 320KB RAM, 4MB Flash
DEBUG: Current (cmsis-dap) External (cmsis-dap, esp-bridge, esp-builtin, esp-prog, iot-bus-jtag, jlink, minimodule, olimex-arm-usb-ocd, olimex-arm-usb-ocd-h, olimex-arm-usb-tiny-h, olimex-jtag-tiny, tumpa)
PACKAGES:
 - framework-arduinoespressif32 @ 3.20011.230801 (2.0.11)
 - tool-esptoolpy @ 1.40501.0 (4.5.1)
 - toolchain-riscv32-esp @ 8.4.0+2021r2-patch5
LDF: Library Dependency Finder -> https://bit.ly/configure-pio-ldf
LDF Modes: Finder ~ chain, Compatibility ~ soft
Found 33 compatible libraries
Scanning dependencies...
No dependencies
Building in release mode
Looking for serial port...
Auto-detected: COM11
Erasing...
esptool.py v4.5.1
Serial port COM11
Connecting...
Chip is ESP32-C3 (revision v0.4)
Features: WiFi, BLE
Crystal is 40MHz
MAC: 48:31:b7:b2:c7:c0
Uploading stub...
Running stub...
Stub running...

A serial exception error occurred: Cannot configure port, something went wrong. Original message: OSError(22, 'È stato specificato un dispositivo inesistente.', None, 433)
Note: This error originates from pySerial. It is likely not a problem with esptool, but with the hardware connection or drivers.       
For troubleshooting steps visit: https://docs.espressif.com/projects/esptool/en/latest/troubleshooting.html
*** [erase] Error 1
===================================================== [FAILED] Took 2.20 seconds =====================================================

I tried to install different drivers.
I tried to use esp-builtin as the upload_protocol but then got a different set of errors. I tried to resolve those using Zadig to install the correct drivers and by installing more drivers with ESP-IDF, but I didn’t manage to fix anything.